SSH-соединение с портом 22 отклонено / истекло время ожидания. Не удается установить ключ на сервер

166
Dre

У меня были проблемы с подключением к моему SSH-серверу. После установки ssh и других серверных пакетов я пытался подключиться как пользователь root. Каждый раз, когда он говорит, что время соединения истекло. Я переустанавливал и пытался переделать файлы конфигурации и настройки роутера, но ничего.

Также ключи, которые я сгенерировал через ssh, не могут быть скопированы на сервер. Когда я пытаюсь скопировать его, он не может установить подлинность хоста и отказывает в разрешении на установку ключей. Ниже приведен код:

ssh -v root@198.168.1.48 OpenSSH_7.8p1 Debian-1, OpenSSL 1.0.2o 27 Mar 2018 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug1: Connecting to 198.168.1.48 [198.168.1.48] port 22. debug1: connect to address 198.168.1.48 port 22: Connection timed out ssh: connect to host 198.168.1.48 port 22: Connection timed out  :~# ssh-copy-id -i ~/serv_key_ecdsa.pub root@Ghost /usr/bin/ssh-copy-id: INFO: Source of key(s) to be installed: "/root/serv_key_ecdsa.pub" The authenticity of host 'ghost (127.0.1.1)' can't be established. ECDSA key fingerprint is SHA256:k4oauVKdQzGIkRtwwMNtLWgqAkr1Yxzr2cn4ouPPX6k. Are you sure you want to continue connecting (yes/no)? yes /usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed /usr/bin/ssh-copy-id: INFO: 1 key(s) remain to be installed -- if you are prompted now it is to install the new keys Permission denied (publickey). 

Я пытаюсь подключиться к серверу впервые, который недавно построил. Какие-либо предложения?

0
You have two different problems. First, `198.168.1.48` either needs (1) a hole punched in the firewall; or (2) the OpenSSH service needs to be installed and started. Your local host may need a firewall TCP/22 opened, but I am guessing you already configured the local machine because you have your keys and you can connect to `127.0.0.1`. Second, the *`Permission denied (publickey)`* is a different problem. You need to enable password authentication for root until the key is installed. Or, just drop it in `/root/.ssh/authorized_keys` by hand. jww 1 год назад 0
@jww Я работаю над настройкой брандмауэра, но разрешил вход с правами root в / etc / ssh / sshd_config. Какая разница? Dre 1 год назад 0

0 ответов на вопрос

Похожие вопросы