Ubuntu 16.04 не может добавить режим 1080p для Xrandr ASUS VS247H-P, NVIDIA

1003
Austin

Я спрашивал об этом уже на форумах Ubuntu, но не смог найти решение, смотрите: https://ubuntuforums.org/showthread.php?t=2341827

Мой монитор 1080p застрял с разрешением 1360x768 в Ubuntu 16.04. Я попытался добавить новый режим в xrandr, но покончить с этой ошибкой:

X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 18 (RRAddOutputMode) Serial number of failed request: 45 Current serial number in output stream: 46 

SPECS

Монитор: Asus VS247H-P

Кабель: Амазонка Основы HDMI

видеокарта: гигабайт windforce gtx970

драйвер: nvidia-367 (пробовал с несколькими драйверами nvidia)

Вот полный метод, который я пытаюсь.

xrandr Screen 0: minimum 8 x 8, current 1360 x 768, maximum 16384 x 16384 DVI-I-0 disconnected (normal left inverted right x axis y axis) DVI-I-1 disconnected (normal left inverted right x axis y axis) HDMI-0 connected primary 1360x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm 1024x768 60.00 + 1360x768 59.96* 59.80  1152x864 60.00  800x600 72.19 60.32 56.25  680x384 59.96 59.80  640x480 59.94  512x384 60.00  400x300 72.19  320x240 60.05  DP-0 disconnected (normal left inverted right x axis y axis) DP-1 disconnected (normal left inverted right x axis y axis) DP-2 disconnected (normal left inverted right x axis y axis) DP-3 disconnected (normal left inverted right x axis y axis) DP-4 disconnected (normal left inverted right x axis y axis) DP-5 disconnected (normal left inverted right x axis y axis)    cvt 1920 1080# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz Modeline "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync    xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync  xrandr --addmode HDMI-0 "1920x1080_60.00"X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 18 (RRAddOutputMode) Serial number of failed request: 45 Current serial number in output stream: 46 

Я довольно новичок в Ubuntu, поэтому я не уверен, какие параметры являются недействительными. Кроме того, если я заставлю это работать, как я сохраню это при запуске?

4
Это случайный выстрел в темноте - но попробуйте сгенерировать режим с более низкой частотой, используя `gtf`. Попробуйте 59 или 55 Гц. Я помню, что помог кому-то с той же проблемой - хотя это был драйвер Intel. Marek Rost 7 лет назад 0
http://arachnoid.com/modelines/ предоставляет несколько иную моделину: Modeline "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync + Vsync glallen 7 лет назад 0
Если ответ не работает - возможно, вам придется отредактировать `xorg.conf`. Смотрите пример по ссылке выше. Смотрите также http://askubuntu.com/a/334404/73056 glallen 7 лет назад 0

1 ответ на вопрос

0
glallen

Пытаться:

xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync 

или же:

xrandr --newmode "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -hsync +vsync 

с последующим:

xrandr --addmode HDMI-0 1920x1080_60.00 xrandr --output HDMI-0 --mode 1920x1080_60.00 

Разница в синтаксисе заключается в кавычках вокруг режима для --addmodeи --output.

В противном случае - см. Соответствующий ответ здесь: https://askubuntu.com/a/334404/73056 и отредактируйте xorg.conf, чтобы добавить Modlines.

Похожие вопросы