Новые вопросы с тегом «postgresql»

Всего найдено 352 вопроса

0
голосов
0
ответов
109
просмотров

Удаленное соединение с PostgreSQL между Mac и Windows PC через роутер не работает

У меня есть 2 ноутбука: один - Mac с PostgreSQL, а другой - Windows 8.1. На моем компьютере с Windows я установил драйвер ODBC для PostgreSQL. Затем я изменил postgresql.confи pg_hba.confдля того, чтобы разрешить удаленное подключение от моего окна Windows к БД. И я попытался настроить соединение OD...
спросил Igor 2 года назад

0
голосов
0
ответов
164
просмотра

Проблемы с Metasploit / postgresql / armitage

Я пытался заставить armitage работать некоторое время, и я не могу найти точного ответа на проблему, с которой я столкнулся, вот так. Когда я открываю armitage, он не может подключиться к базе данных и говорит password auth. failed for user "msf". Я включил службу postgresql. Я не могу запустить слу...
спросил Tyler 2 года назад

2
голосов
0
ответов
345
просмотров

Wildfly 14 Подключение к удаленному PostgreSQL "WFLYJCA0047: Соединение недопустимо"

Я установил новый экземпляр WildFly на CentOS 7. Я пытаюсь создать соединение с удаленным экземпляром PostgreSQL. Я делаю это путем развертывания jar-файла JDBC PostgreSQL в WildFly и создания источника данных с его использованием. Я сделал все это через веб-консоль. Вот моя конфигурация источника д...
спросил Ferdi 2 года назад

0
голосов
0
ответов
107
просмотров

Проблема кодирования базы данных Heroku postgres

Когда я пытаюсь вставить выражение на консоли heroku postgres, арабский символ появляется "????" На Linux все работает нормально, но на Win 10 Powershell кажется, что есть проблема с кодировкой client_encoding = WIN1252 server_encoding = UTF8 Я попытался изменить страницу кодировки Powershell на utf...
спросил MOHAMED OKASHA 2 года назад

0
голосов
0
ответов
91
просмотр

DRBD - / dev / drbd0 отсутствует после перезагрузки

Я обнаружил, что файл блока / dev / drbd0 отсутствовал после перезагрузки. Пожалуйста, советуйте. lrwxrwxrwx 1 root root 10 октября 24 15:20 pgsql -> / dev / drbd0 У вас есть новая почта в / var / spool / mail / root [root @ tsjkdpibi002 by-res] # pwd / dev / drbd / by-res [root @ tsjkdpibi002 by...
спросил Amir Kourdi 2 года назад

0
голосов
0
ответов
86
просмотров

Как запустить сервер PostgreSQL через pg_ctl и оставить его работающим на переднем плане / не демонизировать его?

Я знаком с postgresкомандой и уверен, что понимаю, как ее выполнить pg_ctl. Я хотел бы использовать последний подход для того, чтобы иметь унифицированную структуру команд и иметь возможность комфортно ждать запуска (с --waitкоторым по умолчанию). Как мне продолжать pg_ctl startработать на переднем...
спросил Karl Richter 2 года назад

0
голосов
1
ответ
172
просмотра

Неудовлетворенные зависимости для PostgreSQL 10 под Ubuntu 16.04.5 LTS (xenial)

Следуя официальным инструкциям в https://www.postgresql.org/download/linux/ubuntu/, я получил следующую ошибку: The following packages have unmet dependencies: postgresql-10 : Depends: postgresql-client-10 Depends: libgssapi-krb5-2 (>= 1.14+dfsg) but 1.13.2+dfsg-5ubuntu2 is to be installed Depend...
спросил AntonAL 2 года назад

0
голосов
0
ответов
77
просмотров

Повышение безопасности Linux с помощью специальных групп для базы данных и сервера

Для повышения безопасности я хочу создать 2 группы: database_group можно запустить, перезагрузить, остановить сервер Postgresql можно изменить файлы конфигурации Postgresql из / etc не могу удалить, удалить postgresql и связанные пакеты ! Я говорю не о ролях PostgreSQL, а о ролях пользователей L...
спросил user3541631 2 года назад

0
голосов
1
ответ
102
просмотра

Перехват ошибки команды bash в переменной

Я использую psql(PostgreSQL) команду в скрипте bash: function create_database () { sudo -u postgres psql -c "CREATE DATABASE $1 WITH OWNER $2;" 2>ERROR if [[ $? -ne 0]; then echo "error -> $ERROR" return 1 else: .... return 0 } Я пытаюсь поймать errorи передать его в переменную, но переменная...
спросил user3541631 2 года назад

0
голосов
0
ответов
600
просмотров

Удалить PostgreSQL BigSQL Distro 10.5.1

Установили в BigSQL PostgreSQL дистрибутив версии 10.5.1 . Хотел удалить с компьютера с Windows 10. Использование Добавить / Удалить программы; сообщение об ошибке при удалении => Невозможно найти uninstall.dat Я могу найти файл uninstall.dat в: % installdir% \ uninstall \ uinstall.dat (194Kb)...
спросил Jayden 2 года назад

1
голосов
1
ответ
238
просмотров

Как программно проверить, существует ли база данных и / или пользователь в базе данных PostgreSQL с использованием Bash?

Я хочу написать скрипт bash, который создает несколько пользователей и базу данных. Сначала я хочу проверить, существует ли пользователь, поэтому я попытался sudo -u postgres psql -c 'SELECT 1 FROM pg_roles WHERE rolename=$' Как получить возвращаемое значение, которое я могу проверить в if? Как пр...
спросил user3541631 2 года назад

1
голосов
0
ответов
86
просмотров

Собственная репликация PostgreSQL | Мастер - Мастер

Я настраиваю среду высокой доступности с машиной Debian 9.4, на которой у меня работает Heartbeat и мне нужно включить собственную репликацию PostgreSQL 9.6, но по умолчанию этот метод репликации является однонаправленным, то есть это просто потоковая передача из базы данных от Master кластеризовать...
спросил Alessandro Cardoso 2 года назад

0
голосов
0
ответов
315
просмотров

Невозможно установить PostgreSQL на Win10 из-за getlocales.exe

Я не могу установить несколько версий PostgreSQL(начиная с 9.4.x и выше) Windows 10, скачанных отсюда, каждая из которых сообщает об одной и той же ошибке: Любая идея о том, как преодолеть это? Мне удалось установить 9.5.x на Windows 7. Я искал каталог postgresql_installer * в C: \ Users \% USERNAM...
спросил amphibient 2 года назад

1
голосов
1
ответ
123
просмотра

Как создать строковое соединение odbc в электронной таблице Excel, чтобы сделать его переносимым вместо установки соединения odbc на каждом компьютере?

Я настраиваю отчеты Excel, используя Excel 2013 для этого. Электронная таблица извлекает данные через соединение odbc, которое мне нужно установить на каждом компьютере, чтобы получить данные. Я пытался изменить следующее: Данные> Запрос> Изменить свойство цепочки соединений Это строка подкл...
спросил Andy K 2 года назад

0
голосов
0
ответов
93
просмотра

Как улучшить скрипт резервного копирования базы данных PostgreSQL - используется с crontab

Есть около 15 баз данных для резервного копирования на ежедневной основе. Пароль установлен для пользователя postgres . pg_dumpallвыполняется в начале скрипта для полного резервного копирования. pg_dumpзапускается в том же сценарии для конкретных баз данных в цикле for . Поскольку скрипт будет испол...
спросил zer0mode 2 года назад

0
голосов
0
ответов
118
просмотров

Ошибка запуска pgadmin в Ubuntu

Я установил pgadmin4 на xenial, как это было упомянуто на сайте. Я сделал так, как было указано, и установка прошла успешно, но следующие две ошибки циклически повторяются, и я вообще не могу запустить pgadmin: Что является причиной этого и как мне решить эту проблему?
спросил niceboy-programmer 2 года назад

0
голосов
1
ответ
458
просмотров

Обновите postgresql с 9.4 до 9.6 на Debian Stretch (9.0)

Я хочу обновить свой кластер PostgreSQL 9.4 до PostgreSQL 9.6, так как при обновлении debian до 9.0 (растяжка) я потерял PostgreSQL 9.4, но его больше нет в репозиториях. Без PostgreSQL 9.4 я, однако, не могу обновить с помощью pg_upgradecluster Должен ли я установить PostgreSQL 9.4 с помощью устан...
спросил xuma202 2 года назад

-2
голосов
1
ответ
131
просмотр

Как я могу сделать table_query.sql?

https://github.com/blobmon/simplechan Я иду на улицу на вышеуказанном сайте. Сейчас я делаю базы данных и пользователей. Выйдите из psql, нажав ctrl + D, а также выйдите из пользователя postgres, снова нажав ctrl + D. Оттуда, $ psql - d simplech_db - U simplech_role После ввода я попытался сделать...
спросил user909097 2 года назад

1
голосов
1
ответ
409
просмотров

Fedora 28 не может обновить Postgres до 10

При запуске сервера Postgres на Fedora 28 я получаю эту ошибку: May 25 14:36:14 localhost.localdomain systemd[1]: Starting PostgreSQL database server... May 25 14:36:14 localhost.localdomain postgresql-check-db-dir[11816]: An old version of the database format was found. May 25 14:36:14 localhost.lo...
спросил Bart Friederichs 2 года назад

0
голосов
0
ответов
299
просмотров

Я случайно получаю «rsProcessingAborted» и «rsErrorExecutingCommand» в своем отчете построителя отчетов SQL Server

У меня есть отчет, в котором я случайно получаю следующую ошибку после нажатия кнопки «Просмотреть отчет» (потому что в этом отчете мне нужно сначала выбрать значение параметра в раскрывающемся поле): An error has occurred during report processing. (rsProcessingAborted) Query execution failed for da...
спросил Bruder Lustig 2 года назад

1
голосов
1
ответ
425
просмотров

Подключение к экземпляру postgresql, работающему на VirtualBox

У меня есть виртуальная машина VirtualBox, работающая локально, на которой установлена ​​ОС postgresql 9.6. Я могу подключиться к экземпляру с помощью pgadmin на виртуальной машине. Я пытаюсь подключиться к тому же экземпляру с хост-машины. Я создал правило входящего брандмауэра: Мой файл pg_hba.co...
спросил Mike Cole 2 года назад

0
голосов
0
ответов
231
просмотр

Как я могу узнать, почему установка консоли Nextcloud не генерирует таблицы в ProstgreSQL?

Я пытался установить Nextcloud на свой сервер Alpine-Linux с помощью occ maintenance:install --database "pgsql" --database-name "dbname" ...команды, но меня встречают только исключения. Первоначально жалоба была An unhandled exception has been thrown: Doctrine\DBAL\DBALException: Failed to connect t...
спросил Sty 2 года назад

2
голосов
4
ответа
5581
просмотр

Как исправить pgAdmin 4 v3.0 + номер порта

Я только что установил PostgreSQL 10.4 и заметил, что интерфейс pgAdmin 4 v3.0, поставляемый с этой версией, использует локальный веб-сервер и интерфейс браузера. По умолчанию приложение использует временный порт (от 49152 до 65535), назначенный операционной системой (в моем случае Windows 10). Тем...
спросил Jeff G 2 года назад

1
голосов
5
ответов
2150
просмотров

PostgreSQL 10 не запускается под Ubuntu 18.04

В моей свежей Ubuntu 18.04 - $ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04 LTS Release: 18.04 Codename: bionic Установил PostgreSQL 10 - $ apt list --installed | grep -i postgres postgresql-client-10/bionic,now 10.3-1 amd64 [installed] postgresql-c...
спросил Jerry Ji 2 года назад

0
голосов
0
ответов
76
просмотров

ПостГИС на Fedora27

Я пытаюсь установить PostGIS на Fedora27 и Postgres 9.6. Делая это в Windows, я могу просто использовать Stack Builder, но эта утилита не доступна в дистрибутиве Fedora. Я попытался использовать dnf для установки, но он не может найти репозиторий, и при прямой загрузке RPM, протестированного для Fed...
спросил JGrindal 2 года назад

0
голосов
1
ответ
105
просмотров

суммирование общего количества часов атрибута (отметка времени без часового пояса) с использованием postgreSQL

Я написал следующий запрос SQL, когда пытался подвести итог следующего столбца, но у меня были ошибки, и он не выполняется .. какие-либо идеи .. SELECT NUMTODSINTERVAL(SUM((TO_NUMBER(SUBSTR(sensor.datedahour,1,2))*3600)+(TO_NUMBER(SUBSTR(sensor.datedahour,4,2))*60)+TO_NUMBER(SUBSTR(sensor.datedahou...
спросил AnahedSoftware2018 2 года назад

0
голосов
1
ответ
1114
просмотров

Почему я не могу подключиться к PostgreSQL (локальный сервер), когда мой VPN активен?

Я просто потратил час своей жизни, пытаясь понять, почему pgAdminIII не может подключиться к серверу localhost. Попробовав изменения конфигурации, запустив / остановив службу postgresql и т. Д., Я наконец понял, что с момента последнего использования pgAdminIII изменилось только одно: я был подключе...
спросил Chris Cirefice 2 года назад

0
голосов
0
ответов
341
просмотр

Как добавить инструмент pg-upgrade в gitlab-ctl? «gitlab-ctl status» работает, но «gitlab-ctl pg-upgrade» не работает

Я должен обновить postgresql, чтобы обновить git. Для этого люди говорят «запустите gitlab-ctl pg-upgrade», но когда я это делаю, он говорит мне: «Я не знаю эту команду». плюс список параметров, доступных для команды gitlab-ctl. Почему я не могу использовать опцию pg-upgrade и что мне нужно сделать,...
спросил Philipili 2 года назад

0
голосов
0
ответов
158
просмотров

Docker не будет установлен на Ubuntu 14.04 из-за проблем Postgresql?

Я использую Ubuntu 14.04 LTS. Когда я пытаюсь установить на него докер, я получаю следующие ошибки. У меня были эти ошибки раньше. Они начались, когда я обновился до PostgreSQL, и почему-то версия 9.3 все еще висит. Тем не менее, я установил несколько пакетов с помощью apt-get после того, как ошибки...
спросил Robert Oschler 2 года назад

0
голосов
1
ответ
1344
просмотра

удалить строку с помощью pgadmin III

Для чего-то столь очевидного, что я просто не могу этого сделать. Как я могу просто удалить одну строку, не выполняя команду вручную.
спросил Jamie Hutber 2 года назад